Docker - Fonts not changing -- [Solved]


I’ve just installed Penpot locally with docker via the provided instructions. I’m using the default docker-compose.yaml with no changes, and I’m able to access it and log in at localhost:9001 fine. However, I can’t seem to change the font of any text. I’m referring to just the default Google fonts that come pre-installed; I’m not trying to upload custom fonts. I followed the tutorial project and also created a blank new project and added text, but it seems stuck on a serif font (not even Source Sans Pro). I made sure the text was selected and highlighted before trying to change the font.

I hope I’m just missing something obvious, but it seems pretty simple and straightforward, so maybe I’m running into a Penpot issue.

I’m running Docker version 23.0.1 on Arch Linux. All the docker images pulled are the latest as of today, 3/7/23. Please let me know what relevant info or logs may be helpful.

Edit: forgot to mention that I was using Firefox 110.0.1. I tried again in Brave, and it seems to be working fine. Marking solved, and I will just use a Chromium-based browser.

Edit 2: Turns out it was my Firefox settings. In about:preferences > Fonts > Advanced I had unchecked “Allow pages to choose their own fonts, instead of your selections above” so I was overriding the CSS from Penpot. I checked it and it’s working fine now. Hopefully this facepalm moment will help someone else…

1 Like