Penpot suddenly started freezing anytime I try to modify or delete any object

I’ve gotten pretty far into design for a project using Penpot, but suddenly I am unable to delete any layer or move any layer into another. When I try, the tab freezes immediately. This happens in both Chrome and Firefox on a Mac.

I’m not sure how to proceed. Right now, all my work for this project is locked up in this uneditable file and I’m having a minor freakout. I tried exporting the .penpot file and re-importing it, but that did not help. It’s only 451 KB when exported, so it doesn’t seem like it would be a memory issue.

I guess I needed to make a public post in order to solve the issue. :confused:

Right after posting, I tried moving/deleting elements on a different board and it worked without freezing. So I deleted the problem board and started over, and now it’s all working again.

My approach going forward will be to constantly export .penpot files from a working state every time I accomplish something. I’m still curious if anyone has experienced the same and has tips.

I’m actually stuck right now with a file I was working on, suddenly penpot is crashing every time I try to touch it.

Sorry to hear that. To try to pinpoint the problem would be great to have access to your file. Could you export it from the dashboard (right click on the file > export .penpot) and send the file to


Just an update—I did send my file to the Penpot team but have not heard back. I’ve continued using Penpot for the last 2 weeks and have not encountered the same issue again, though I’m struggling with others. I’ve been regularly exporting .penpot files when each project gets to a workable stopping point, but have not needed to revert to any of them yet.

Exporting out important progress is good practice. With any update, could come new bugs. Glade, it seems that you have landed in a good place. I had issues today as well, lost some work after refreshing the screen. Then started listening to my advice :).