Penpot is crashing when Assets tab is selected, malformed asset?

I’m having the same issue described here.

I created a magnifying glass graphic of an ellipse and one line segment. I marked it as a component and noticed the scaling was strange so I flattened the two components and created a union of them. After doing one or both of these steps, the scaling was working on the board I have the icon on. On my main layout, the scaling was strange so I went to the graphic and chose the option to “update main component”. After doing this, I can no longer access the assets tab.

I think the graphic I created has some kind of error the webui can’t handle, but I have no idea how to remove it from assets when I can’t access the assets tab without the page crashing.

How do I edit a penpot file outside of penpot? I would like to remove the bad data so I can continue editing the same file. It would be really unhelpful if I had to start over.

You can export the file to a zip file containing standard svg and json: at the main file menu, select “Download as
standard file”.

Then you can inspect it to see if there is something wrong, and then reimport it again. Sometimes the problem solves simply by exporting and reimporting it.

Anyway, It will be good if you share your file with us, for us to investigate what is the cause and solve it. You can share it here, or send it to for us to handle it privately.

Thanks for the suggestion. I tried exporting as a standard file, but I’m getting a red x on the export progress window.


I tried to upload my penpot file, but the forum won’t let me because I’m too new of a user. I’ve sent an email to support. I’ll also update this thread with the solution if anyone in the future has the same issue and this troubleshooting can be of assistance

This issue has been resolved thanks to the amazing people at Penpot support.

It was caused by a bug where using “transform to path” on a component causes an invalid asset shape. It’s currently being fixed.

We also have simular issue with our design system library file? what is the best way to solve this?