Why some components' inner content moves during drag and drop into a grid?


I am creating a design system with components v2, however as shown in the link below, I am having an issue with my input components. Whenever I drag and drop them into a grid layout, the inner content keeps moving instead of snapping with the container. I am not sure if it is a bug or if I am doing something wrong… For information, it’s a board with a grid layout, and it happens with both the main component and the “variant” main components. However, with icons or buttons, I do not have this issue… Does someone has any explanation and know how to avoid it ? This slows me down a lot as I can’t find a way to not get this behavior (I tried copy paste, drag and drop from the assets and from outside the board too, I tried to see if there was a possibility to reset to main, which doesn’t seem to show up).

I know that the inner structure can’t change in this new system. I am not trying to do any of it, this modification is accidental, I don’t know how to not trigger it.

here is the link with a video to make it easier to understand. If it is not clear please let me know.

Thanks in advance, and sorry if I am not posting in the right place or if it is trivial :sweat_smile:


1 Like

Through additional experimentations, it seems to be a behavior between a component with a grid layout and a frame with a grid layout in general. Here is a penpot file that allows to reproduce the behavior (dragging the blue component copy into the grid frame). I am still not sure if it is a bug…

grid and components problem.penpot (15.0 KB)