Unable to disable user registration in self hosted Penpot

I have a self hosted instance of Penpot using docker. I want to disable user registration as per

I set up the docker-compose.penpot.env file variable as PENPOT_REGISTRATION_ENABLED=false but still the registrations link is enabled. How to disable registration ?

Hello @panchtatvam
Many configuration variables was deprecrated for some releases (they are replaced with flags) and in the last release the support for for that variables is removed (penpot/CHANGES.md at develop · penpot/penpot · GitHub)

Here you can see how to disable registration:

1 Like

Thank you. I was able to make this work only if I use penpot separately from Taiga. I did use the new enabled flags as well instead of the old one.

Hello,
I want to run my own penpot instance so I can work regardless of internet connection. I set both backend and frontend flags as:

      - PENPOT_FLAGS=disable-registration disable-login-with-password
      - PENPOT_FLAGS=disable-registration enable-insecure-register disable-login disable-email-verification enable-smtp enable-prepl-server

Now I’m stuck on Great to see you again!


I can’t get past http://localhost:9001/#/auth/login
Not sure if there’s anything else I should change, and I don’t see any errors on the console.
:crazy_face: :loop: :curly_loop: :loop: :cyclone: