"Bad Gateway" error on Raspberry Pi

Hey guys, I recently came accros this software and wanted to try self-host this. I followed the installation guide exactly but I always get that “Bad Gateway” error. I tested it on a Raspberry Pi 4 with a fresh installation of the latest Ubuntu LTS (installed yesterday) and on a Windows machine using Docker for Windows (i.e. over WSL2). After adding a user via create-profile it works on windows but still not on my Pi. On my Pi I used a custom docker compose file, but tried the one officially provided , too, of course (both gav eme the same error).

Thanks in advance!

Oh, btw, here are my custom docker compose file and the logs from docker compose logs
Logs after starting the containers

Logs after creating a profile
Logs after the first request
TLDR: The only difference is 172.22.0.1 - - [11/Jan/2024:23:55:17 +0000] "GET /api/rpc/command/get-profile HTTP/1.1" 502 150 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:121.0) Gecko/20100101 Firefox/121.0" in the frontend’s container’s log after making a request to :9001 (or :9060 for the custom docker compose file).

(Sorry for the many replies, i cannot post more than 2 links at once)

Did you solve the issue? I have same experience. Internal Error on RP4

Unfortunstely, no. And I habe absolutely no idea what the problem might be.