Penpot in Podman

I know there’s this thread (which is a bit more outdated): How to develop penpot with podman (penpotman)

But it seems like the original author didn’t get it fully working w/ Podman.

As I’m not a big fan of Docker and moving all my containerization to Podman, I went and got a running set up going, and pushed up my efforts to a public repo here - GitHub - ThirteenTwoConsulting/PenpotPodman

If there’s interest on a cleaner understanding of what to do let me know, but it’s pretty straight forward once you have Podman installed on your system.

One clean up that can happen is to use a pod instead of doing things like this, but this has been more of a PoC than anything else for me.


Hi, nice you got it running and thanks for sharing this on github.
May I ask what system you deployed it on?

I haven’t tried it recently on Ubuntu (and don’t plan to) but would be more than happy to add a tested version to the list on the original post, so people know what is running where :slight_smile:

@constant-flow certainly. I run OpenSUSE Tumbleweed, but it should work with anything that allows a user to run Podman or Docker (or really any other OCI-compliant set up). It’s very bare bones so it’s not something that requires a lot of new features.